BooleanPropertyEditor Class
Boolean Property Editor registered for the "bool" and "boolean" type names. It uses the BooleanEditor React component.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): BooleanPropertyEditor |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void | PropertyEditorBase | |
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> | PropertyEditorBase | |
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> | PropertyEditorBase |
Properties
Name | Type | Description | |
---|---|---|---|
containerHandlesBlur Accessor ReadOnly | boolean | ||
reactNode Accessor ReadOnly | ReactNode |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
containerHandlesEnter Accessor ReadOnly | boolean | PropertyEditorBase | |
containerHandlesEscape Accessor ReadOnly | boolean | PropertyEditorBase | |
containerHandlesTab Accessor ReadOnly | boolean | PropertyEditorBase | |
containerStopsKeydownPropagation Accessor ReadOnly | boolean | PropertyEditorBase | |
customDataController | undefined | DataController | PropertyEditorBase |
Defined in
Last Updated: 20 June, 2023