TextareaPropertyEditor Class
Textarea Property Editor registered for the "text" and "string" type names and "multi-line" editor name. It uses the Textarea React component.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): TextareaPropertyEditor |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void | PropertyEditorBase | |
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> | PropertyEditorBase | |
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> | PropertyEditorBase |
Properties
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
containerHandlesEscape Accessor ReadOnly | boolean | PropertyEditorBase | |
containerStopsKeydownPropagation Accessor ReadOnly | boolean | PropertyEditorBase | |
customDataController | undefined | DataController | PropertyEditorBase |
Defined in
Last Updated: 20 June, 2023