EnumPropertyButtonGroupEditor Class
Enum Property Button Group Editor registered for the "enum" type name and the "enum-buttongroup" editor name. It uses the EnumButtonGroupEditor React component.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): EnumPropertyButtonGroupEditor |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void | PropertyEditorBase | |
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> | PropertyEditorBase | |
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> | PropertyEditorBase |
Properties
Name | Type | Description | |
---|---|---|---|
reactNode Accessor ReadOnly | ReactNode |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
containerHandlesBlur Accessor ReadOnly | boolean | PropertyEditorBase | |
containerHandlesEnter Accessor ReadOnly | boolean | PropertyEditorBase | |
containerHandlesEscape Accessor ReadOnly | boolean | PropertyEditorBase | |
containerHandlesTab Accessor ReadOnly | boolean | PropertyEditorBase | |
containerStopsKeydownPropagation Accessor ReadOnly | boolean | PropertyEditorBase | |
customDataController | undefined | DataController | PropertyEditorBase |
Defined in
Last Updated: 20 June, 2023