ContentModifier Interface
Content modifiers are used to modify how instances of specified ECClasses are displayed in content which is produced using content rules. They do not produce any content by themselves.
see Content modifier rule reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
class | undefined | SingleSchemaClassSpecification | Specification of ECClass whose content should be modified. | |
ruleType | "ContentModifier" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties | undefined | CalculatedPropertiesSpecification[] | ContentModifiersList | Specifications of calculated properties whose values are |
onlyIfNotHandled | undefined | boolean | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority | undefined | number | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
propertyCategories | undefined | PropertyCategorySpecification[] | ContentModifiersList | Specifications for custom categories. |
propertyOverrides | undefined | PropertySpecification[] | ContentModifiersList | Specifications for various property overrides that allow customizing property display. |
relatedProperties | undefined | RelatedPropertiesSpecification[] | ContentModifiersList | Specifications of related properties which are |
requiredSchemas | undefined | RequiredSchemaSpecification[] | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 20 June, 2023