PropertySpecification Interface
This specification allows overriding some attributes of specific ECProperty or define how it's displayed.
see Property specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
name | string | Name of the ECProperty to apply overrides to. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categoryId | string | CategoryIdentifier | PropertyOverrides | The attribute allows moving the property into a different category. |
doNotHideOtherPropertiesOnDisplayOverride | undefined | boolean | PropertyOverrides | This attribute controls whether making the property visible using PropertyOverrides.isDisplayed attribute should automatically hide |
editor | undefined | PropertyEditorSpecification | PropertyOverrides | Custom property editor specification that allows assigning |
isDisplayed | string | boolean | PropertyOverrides | This attribute controls whether the particular property is present in the result, even when it is marked as hidden in the |
isReadOnly | undefined | boolean | PropertyOverrides | This attribute controls whether the property field is read-only. |
labelOverride | undefined | string | PropertyOverrides | This is an attribute that allows overriding the property label. |
overridesPriority | undefined | number | PropertyOverrides | There may be multiple property specifications that apply to a single property and there may be conflicts between |
priority | undefined | number | PropertyOverrides | This attribute controls the order in which property fields should be displayed. |
renderer | undefined | CustomRendererSpecification | PropertyOverrides | Custom property renderer specification that allows assigning a |
Defined in
Last Updated: 20 June, 2023