PropertyOverrides Interface
A container structure for possible property overrides
see Property specification reference documentation page
Properties
Name | Type | Description | |
---|---|---|---|
categoryId | string | CategoryIdentifier | The attribute allows moving the property into a different category. | |
doNotHideOtherPropertiesOnDisplayOverride | undefined | boolean | This attribute controls whether making the property visible using PropertyOverrides.isDisplayed attribute should automatically hide | |
editor | undefined | PropertyEditorSpecification | Custom property editor specification that allows assigning | |
isDisplayed | string | boolean | This attribute controls whether the particular property is present in the result, even when it is marked as hidden in the | |
isReadOnly | undefined | boolean | This attribute controls whether the property field is read-only. | |
labelOverride | undefined | string | This is an attribute that allows overriding the property label. | |
overridesPriority | undefined | number | There may be multiple property specifications that apply to a single property and there may be conflicts between | |
priority | undefined | number | This attribute controls the order in which property fields should be displayed. | |
renderer | undefined | CustomRendererSpecification | Custom property renderer specification that allows assigning a |
Defined in
Last Updated: 20 June, 2023