MultiManagerPresentationProps Interface
Props for initializing the Presentation library for using multiple PresentationManager instances, one for each frontend.
Extends
Methods
Name | Description | |
---|---|---|
clientManagerFactory(clientId: string, props: PresentationManagerProps): PresentationManager Optional | Factory method for creating separate managers for each client |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getLocalizedString(key: string): string Optional | PresentationPropsBase | Localization function when only backend is used. |
Properties
Name | Type | Description | |
---|---|---|---|
unusedClientLifetime | undefined | number | How much time should an unused client manager be stored in memory |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
caching | undefined | PresentationManagerCachingConfig | PresentationPropsBase | Options for caching. |
defaultFormats | undefined | { T } | PresentationPropsBase | A map of default unit formats to use for formatting properties that don't have a presentation format |
defaultLocale | undefined | string | PresentationPropsBase | Sets the active locale to use when localizing presentation-related |
defaultUnitSystem | undefined | UnitSystemKey | PresentationPropsBase | Sets the active unit system to use for formatting property values with |
diagnostics | undefined | BackendDiagnosticsOptions<any> | PresentationPropsBase | Parameters for gathering diagnostics at the manager level. |
enableSchemasPreload | undefined | boolean | PresentationPropsBase | Should schemas preloading be enabled. |
localeDirectories | undefined | string[] | PresentationPropsBase | A list of directories containing application's locale-specific localized |
mode | undefined | PresentationManagerMode | PresentationPropsBase | Presentation manager working mode. |
presentationAssetsRoot | string | PresentationAssetsRootConfig | PresentationPropsBase | Path overrides for presentation backend assets. |
requestTimeout | undefined | number | PresentationPropsBase | Time in milliseconds after which the request will timeout. |
rulesetDirectories | undefined | string[] | PresentationPropsBase | A list of directories containing application's presentation rulesets. |
supplementalRulesetDirectories | undefined | string[] | PresentationPropsBase | A list of directories containing application's supplemental presentation rulesets. |
updatesPollInterval | undefined | number | PresentationPropsBase | The interval (in milliseconds) used to poll for presentation data changes. |
useMmap | number | boolean | PresentationPropsBase | Use SQLite's Memory-Mapped I/O for worker connections. |
workerThreadsCount | undefined | number | PresentationPropsBase | A number of worker threads to use for handling presentation requests. |
Defined in
Last Updated: 20 June, 2023