PresentationPropsBase Interface
Base props for initializing the Presentation library.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
getLocalizedString(key: string): string Optional | PresentationManagerProps | Localization function when only backend is used. |
Properties
Name | Type | Description | |
---|---|---|---|
enableSchemasPreload | undefined | boolean | Should schemas preloading be enabled. | |
requestTimeout | undefined | number | Time in milliseconds after which the request will timeout. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
caching | undefined | PresentationManagerCachingConfig | PresentationManagerProps | Options for caching. |
defaultFormats | undefined | { T } | PresentationManagerProps | A map of default unit formats to use for formatting properties that don't have a presentation format |
defaultLocale | undefined | string | PresentationManagerProps | Sets the active locale to use when localizing presentation-related |
defaultUnitSystem | undefined | UnitSystemKey | PresentationManagerProps | Sets the active unit system to use for formatting property values with |
diagnostics | undefined | BackendDiagnosticsOptions<any> | PresentationManagerProps | Parameters for gathering diagnostics at the manager level. |
localeDirectories | undefined | string[] | PresentationManagerProps | A list of directories containing application's locale-specific localized |
mode | undefined | PresentationManagerMode | PresentationManagerProps | Presentation manager working mode. |
presentationAssetsRoot | string | PresentationAssetsRootConfig | PresentationManagerProps | Path overrides for presentation backend assets. |
rulesetDirectories | undefined | string[] | PresentationManagerProps | A list of directories containing application's presentation rulesets. |
supplementalRulesetDirectories | undefined | string[] | PresentationManagerProps | A list of directories containing application's supplemental presentation rulesets. |
updatesPollInterval | undefined | number | PresentationManagerProps | The interval (in milliseconds) used to poll for presentation data changes. |
useMmap | number | boolean | PresentationManagerProps | Use SQLite's Memory-Mapped I/O for worker connections. |
workerThreadsCount | undefined | number | PresentationManagerProps | A number of worker threads to use for handling presentation requests. |
Defined in
Last Updated: 20 June, 2023