PresentationManagerProps Interface
Properties that can be used to configure PresentationManager
Methods
Name | Description | |
---|---|---|
getLocalizedString(key: string): string Optional | Localization function when only backend is used. | Beta |
Properties
Name | Type | Description | |
---|---|---|---|
caching | undefined | PresentationManagerCachingConfig | Options for caching. | |
defaultFormats | undefined | { T } | A map of default unit formats to use for formatting properties that don't have a presentation format | |
defaultLocale | undefined | string | Sets the active locale to use when localizing presentation-related | Deprecated |
defaultUnitSystem | undefined | UnitSystemKey | Sets the active unit system to use for formatting property values with | |
diagnostics | undefined | BackendDiagnosticsOptions<any> | Parameters for gathering diagnostics at the manager level. | Beta |
enableSchemasPreload | undefined | boolean | Should schemas preloading be enabled. | Deprecated |
localeDirectories | undefined | string[] | A list of directories containing application's locale-specific localized | Deprecated |
mode | undefined | PresentationManagerMode | Presentation manager working mode. | Deprecated |
presentationAssetsRoot | string | PresentationAssetsRootConfig | Path overrides for presentation backend assets. | |
rulesetDirectories | undefined | string[] | A list of directories containing application's presentation rulesets. | |
supplementalRulesetDirectories | undefined | string[] | A list of directories containing application's supplemental presentation rulesets. | |
updatesPollInterval | undefined | number | The interval (in milliseconds) used to poll for presentation data changes. | Beta |
useMmap | number | boolean | Use SQLite's Memory-Mapped I/O for worker connections. | Beta |
workerThreadsCount | undefined | number | A number of worker threads to use for handling presentation requests. |
Defined in
Last Updated: 20 June, 2023