BackendDiagnosticsOptions<TContext> Interface
Beta
Data structure for backend diagnostics options.
Extends
Methods
Name | Description | |
---|---|---|
requestContextSupplier(): TContext Optional | An optional function to supply request context that'll be passed to BackendDiagnosticsOptions.handler when |
Properties
Name | Type | Description | |
---|---|---|---|
handler | BackendDiagnosticsHandler<TContext> | Request diagnostics handler function that is called after the request is fulfilled. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
dev | boolean | DiagnosticsLoggerSeverity | DiagnosticsOptions | Severity for developer log messages |
editor | boolean | DiagnosticsLoggerSeverity | DiagnosticsOptions | Severity for presentation rules' editor log messages |
perf | boolean | { minimumDuration: number } | DiagnosticsOptions | Flag specifying that performance should be measured, or |
Defined in
Last Updated: 20 June, 2023