LinearlyReferencedAtLocation Class
Beta
Concrete multi-aspect class carrying 'at' linearly-referenced positions along a Linear-Element.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: LinearlyReferencedAtLocationAspectProps, iModel: IModelDb): LinearlyReferencedAtLocation | ||
create(iModel: IModelDb, locatedElementId: string, at: DistanceExpression, fromReferentId?: string): LinearlyReferencedAtLocation Static | ||
insert(iModel: IModelDb, locatedElementId: string, at: DistanceExpression, fromReferentId?: string): void Static |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: Set<string>): void Protected | LinearlyReferencedLocation | Collect the Ids of this entity's references at this level of the class hierarchy. |
forEachProperty(func: PropertyCallback, includeCustom?: boolean): void | LinearlyReferencedLocation | Call a function for each property of this Entity. |
getReferenceIds(): Set<string> | LinearlyReferencedLocation | Get the Ids of this element's references. |
is(otherClass: undefined): boolean Static | LinearlyReferencedLocation | return whether this Entity class is a subclass of another Entity class |
onDelete(_arg: OnAspectIdArg): void ProtectedStatic | LinearlyReferencedLocation | Called before an ElementAspect is deleted. |
onDeleted(_arg: OnAspectIdArg): void ProtectedStatic | LinearlyReferencedLocation | Called after an ElementAspect was deleted. |
onInsert(_arg: OnAspectPropsArg): void ProtectedStatic | LinearlyReferencedLocation | Called before a new ElementAspect is inserted. |
onInserted(_arg: OnAspectPropsArg): void ProtectedStatic | LinearlyReferencedLocation | Called after a new ElementAspect was inserted. |
onUpdate(_arg: OnAspectPropsArg): void ProtectedStatic | LinearlyReferencedLocation | Called before an ElementAspect is updated. |
onUpdated(_arg: OnAspectPropsArg): void ProtectedStatic | LinearlyReferencedLocation | Called after an ElementAspect was updated. |
Properties
Name | Type | Description | |
---|---|---|---|
atPosition | DistanceExpression | ||
fromReferent | undefined | LinearlyReferencedAtPositionRefersToReferent |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | LinearlyReferencedLocation | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly | string | LinearlyReferencedLocation | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | LinearlyReferencedLocation | The name of the BIS class associated with this class. |
element | RelatedElement | LinearlyReferencedLocation | |
id | string | LinearlyReferencedLocation | The Id of this Entity. |
iModel | IModelDb | LinearlyReferencedLocation | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | LinearlyReferencedLocation | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static | undefined | LinearlyReferencedLocation | The Schema that defines this class. |
schemaName Accessor ReadOnly | string | LinearlyReferencedLocation | The name of the BIS Schema that defines this class |
Defined in
Last Updated: 20 June, 2023