DistanceExpression Class
Beta
Core structure carrying linearly-referenced information.
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: DistanceExpressionProps): DistanceExpression | ||
fromJSON(json: DistanceExpressionProps): DistanceExpression Static |
Properties
Name | Type | Description | |
---|---|---|---|
distanceAlongFromReferent | undefined | number | ||
distanceAlongFromStart | number | ||
lateralOffsetFromILinearElement | undefined | number | ||
verticalOffsetFromILinearElement | undefined | number |
Defined in
Last Updated: 20 June, 2023