LinearlyLocated Class
Beta
A class offering services for LinearlyLocated elements.
Methods
Name | Description | |
---|---|---|
constructor(): LinearlyLocated | ||
getAtLocation(iModel: IModelDb, linearlyLocatedElementId: string): undefined | LinearlyReferencedAtLocation Static | Query for the single LinearlyReferenced AtLocation aspect owned by the specified LinearlyLocated Element. | |
getAtLocations(iModel: IModelDb, linearlyLocatedElementId: string): LinearlyReferencedAtLocation[] Static | Query for LinearlyReferenced AtLocation aspects owned by the specified LinearlyLocated Element. | |
getFromToLocation(iModel: IModelDb, linearlyLocatedElementId: string): undefined | LinearlyReferencedFromToLocation Static | Query for the single LinearlyReferenced FromToLocation aspect owned by the specified LinearlyLocated Element. | |
getFromToLocations(iModel: IModelDb, linearlyLocatedElementId: string): LinearlyReferencedFromToLocation[] Static | Query for LinearlyReferenced FromToLocation aspects owned by the specified LinearlyLocated Element. | |
getLinearElementId(iModel: IModelDb, linearlyLocatedElementId: string): undefined | string Static | Query for the Id of the Linear-Element along which the specified LinearlyLocated Element is located. | |
insertAt(iModel: IModelDb, elProps: ElementProps, linearElementId: string, atPosition: LinearlyReferencedAtLocationProps): string Static | Insert a new LinearlyLocated element into an iModel at a specific location along an existing Linear-Element. | |
insertFromTo(iModel: IModelDb, elProps: ElementProps, linearElementId: string, fromToPosition: LinearlyReferencedFromToLocationProps): string Static | Insert a new LinearlyLocated element into an iModel at a specific from-to location along an existing Linear-Element. | |
updateAtLocation(iModel: IModelDb, linearlyLocatedElementId: string, linearLocationProps: LinearlyReferencedAtLocationProps, aspectId?: string): void Static | Update an existing LinearlyReferencedAtLocation aspect within the iModel. | |
updateFromToLocation(iModel: IModelDb, linearlyLocatedElementId: string, linearLocationProps: LinearlyReferencedFromToLocationProps, aspectId?: string): void Static | Update an existing LinearlyReferencedFromToLocation aspect within the iModel. |
Defined in
Last Updated: 20 June, 2023