StructArrayProperty Class
Beta
Extends
Methods
Inherited methods
Inherited properties
Name |
Type |
Inherited from |
Description |
_category Protected |
undefined | LazyLoadedPropertyCategory |
ArrayPropertyMixin(StructProperty) |
|
_class Protected |
AnyClass |
ArrayPropertyMixin(StructProperty) |
|
_description Protected |
undefined | string |
ArrayPropertyMixin(StructProperty) |
|
_isReadOnly Protected |
undefined | boolean |
ArrayPropertyMixin(StructProperty) |
|
_kindOfQuantity Protected |
undefined | LazyLoadedKindOfQuantity |
ArrayPropertyMixin(StructProperty) |
|
_label Protected |
undefined | string |
ArrayPropertyMixin(StructProperty) |
|
_maxOccurs Protected |
undefined | number |
ArrayPropertyMixin(StructProperty) |
|
_minOccurs Protected |
number |
ArrayPropertyMixin(StructProperty) |
|
_name Protected |
ECName |
ArrayPropertyMixin(StructProperty) |
|
_priority Protected |
undefined | number |
ArrayPropertyMixin(StructProperty) |
|
_structClass Protected |
StructClass |
ArrayPropertyMixin(StructProperty) |
|
_type Protected |
PropertyType |
ArrayPropertyMixin(StructProperty) |
|
category Accessor ReadOnly |
undefined | LazyLoadedPropertyCategory |
ArrayPropertyMixin(StructProperty) |
|
class Accessor ReadOnly |
AnyClass |
ArrayPropertyMixin(StructProperty) |
|
customAttributes Accessor ReadOnly |
undefined | |
ArrayPropertyMixin(StructProperty) |
|
description Accessor ReadOnly |
undefined | string |
ArrayPropertyMixin(StructProperty) |
|
fullName Accessor ReadOnly |
string |
ArrayPropertyMixin(StructProperty) |
Returns the name in the format 'ClassName.PropertyName'. |
isReadOnly Accessor ReadOnly |
boolean |
ArrayPropertyMixin(StructProperty) |
|
kindOfQuantity Accessor ReadOnly |
undefined | LazyLoadedKindOfQuantity |
ArrayPropertyMixin(StructProperty) |
|
label Accessor ReadOnly |
undefined | string |
ArrayPropertyMixin(StructProperty) |
|
maxOccurs Accessor ReadOnly |
undefined | number |
ArrayPropertyMixin(StructProperty) |
|
minOccurs Accessor ReadOnly |
number |
ArrayPropertyMixin(StructProperty) |
|
name Accessor ReadOnly |
string |
ArrayPropertyMixin(StructProperty) |
|
priority Accessor ReadOnly |
number |
ArrayPropertyMixin(StructProperty) |
|
propertyType Accessor ReadOnly |
PropertyType |
ArrayPropertyMixin(StructProperty) |
|
schema Accessor ReadOnly |
Schema |
ArrayPropertyMixin(StructProperty) |
Returns the schema of the class holding the property. |
structClass Accessor ReadOnly |
StructClass |
ArrayPropertyMixin(StructProperty) |
|
Defined in
Last Updated:
20 June, 2023