NavigationProperty Class
Beta
Extends
Methods
Name | Description | |
---|---|---|
constructor(ecClass: ECClass, name: string, relationship: LazyLoadedRelationshipClass, direction?: StrengthDirection): NavigationProperty | ||
getRelationshipClassSync(): undefined | RelationshipClass | ||
toJSON(): NavigationPropertyProps | Save this NavigationProperty's properties to an object for serializing to JSON. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addCustomAttribute(customAttribute: CustomAttribute): void Protected | Property | |
fromJSON(propertyProps: PropertyProps): Promise<void> | Property | |
fromJSONSync(propertyProps: PropertyProps): void | Property | |
getCategorySync(): undefined | PropertyCategory | Property | |
getCustomAttributes(): Promise<> | Property | Retrieve all custom attributes in the current property and its base |
getCustomAttributesSync(): | Property | Retrieve all custom attributes in the current property and its base. |
getKindOfQuantitySync(): undefined | KindOfQuantity | Property | |
isArray(): this is AnyArrayProperty | Property | |
isEnumeration(): this is AnyEnumerationProperty | Property | |
isNavigation(): this is NavigationProperty | Property | |
isPrimitive(): this is AnyPrimitiveProperty | Property | |
isStruct(): this is AnyStructProperty | Property |
Properties
Name | Type | Description | |
---|---|---|---|
_direction Protected | StrengthDirection | ||
_relationshipClass Protected | LazyLoadedRelationshipClass | ||
direction Accessor ReadOnly | StrengthDirection | ||
relationshipClass Accessor ReadOnly | LazyLoadedRelationshipClass |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_category Protected | undefined | LazyLoadedPropertyCategory | Property | |
_class Protected | AnyClass | Property | |
_description Protected | undefined | string | Property | |
_isReadOnly Protected | undefined | boolean | Property | |
_kindOfQuantity Protected | undefined | LazyLoadedKindOfQuantity | Property | |
_label Protected | undefined | string | Property | |
_name Protected | ECName | Property | |
_priority Protected | undefined | number | Property | |
_type Protected | PropertyType | Property | |
category Accessor ReadOnly | undefined | LazyLoadedPropertyCategory | Property | |
class Accessor ReadOnly | AnyClass | Property | |
customAttributes Accessor ReadOnly | undefined | | Property | |
description Accessor ReadOnly | undefined | string | Property | |
fullName Accessor ReadOnly | string | Property | Returns the name in the format 'ClassName.PropertyName'. |
isReadOnly Accessor ReadOnly | boolean | Property | |
kindOfQuantity Accessor ReadOnly | undefined | LazyLoadedKindOfQuantity | Property | |
label Accessor ReadOnly | undefined | string | Property | |
name Accessor ReadOnly | string | Property | |
priority Accessor ReadOnly | number | Property | |
propertyType Accessor ReadOnly | PropertyType | Property | |
schema Accessor ReadOnly | Schema | Property | Returns the schema of the class holding the property. |
Defined in
Last Updated: 20 June, 2023