PrimitiveProperty Class
Beta
Extends
Methods
Name | Description | |
---|---|---|
constructor(ecClass: ECClass, name: string, primitiveType: PrimitiveType = PrimitiveType.Integer): PrimitiveProperty | ||
fromJSON(primitivePropertyProps: PrimitivePropertyProps): Promise<void> | ||
fromJSONSync(primitivePropertyProps: PrimitivePropertyProps): void | ||
toJSON(): PrimitivePropertyProps | Save this PrimitiveProperty's properties to an object for serializing to JSON. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addCustomAttribute(customAttribute: CustomAttribute): void Protected | PrimitiveOrEnumPropertyBase | |
getCategorySync(): undefined | PropertyCategory | PrimitiveOrEnumPropertyBase | |
getCustomAttributes(): Promise<> | PrimitiveOrEnumPropertyBase | Retrieve all custom attributes in the current property and its base |
getCustomAttributesSync(): | PrimitiveOrEnumPropertyBase | Retrieve all custom attributes in the current property and its base. |
getKindOfQuantitySync(): undefined | KindOfQuantity | PrimitiveOrEnumPropertyBase | |
isArray(): this is AnyArrayProperty | PrimitiveOrEnumPropertyBase | |
isEnumeration(): this is AnyEnumerationProperty | PrimitiveOrEnumPropertyBase | |
isNavigation(): this is NavigationProperty | PrimitiveOrEnumPropertyBase | |
isPrimitive(): this is AnyPrimitiveProperty | PrimitiveOrEnumPropertyBase | |
isStruct(): this is AnyStructProperty | PrimitiveOrEnumPropertyBase |
Properties
Name | Type | Description | |
---|---|---|---|
primitiveType Accessor ReadOnly | PrimitiveType |
Inherited properties
Defined in
Last Updated: 20 June, 2023