OverrideFormat Class
Beta
Overrides of a Format, from a Schema, and is SchemaItem that is used specifically on KindOfQuantity.
Methods
Name | Description | |
---|---|---|
constructor(parent: Format, precision?: DecimalPrecision | FractionalPrecision, unitAndLabels?: [Unit | InvertedUnit, undefined | string][]): OverrideFormat | ||
hasFormatTrait(formatTrait: FormatTraits): boolean | ||
createOverrideFormatFullName(parent: Format, precision?: DecimalPrecision | FractionalPrecision, unitAndLabels?: [Unit | InvertedUnit, undefined | string][]): string Static | Creates a valid OverrideFormat fullName from the parent Format and overridden units. |
Properties
Name | Type | Description | |
---|---|---|---|
decimalSeparator Accessor ReadOnly | string | ||
formatTraits Accessor ReadOnly | FormatTraits | ||
fullName Accessor ReadOnly | string | ||
includeZero Accessor ReadOnly | undefined | boolean | ||
minWidth Accessor ReadOnly | undefined | number | ||
name Readonly | string | The name of this OverrideFormat. | |
parent Readonly | Format | The Format that this OverrideFormat is extending | |
precision Accessor ReadOnly | DecimalPrecision | FractionalPrecision | ||
roundFactor Accessor ReadOnly | number | ||
scientificType Accessor ReadOnly | undefined | ScientificType | ||
showSignOption Accessor ReadOnly | ShowSignOption | ||
spacer Accessor ReadOnly | undefined | string | ||
stationOffsetSize Accessor ReadOnly | undefined | number | ||
stationSeparator Accessor ReadOnly | string | ||
thousandSeparator Accessor ReadOnly | string | ||
type Accessor ReadOnly | FormatType | ||
units Accessor ReadOnly | undefined | [Unit | InvertedUnit, undefined | string][] | ||
uomSeparator Accessor ReadOnly | string |
Defined in
Last Updated: 20 June, 2023