EnumerationProperty Class
Beta
Extends
Methods
Name | Description | |
---|---|---|
constructor(ecClass: ECClass, name: string, type: LazyLoadedEnumeration): EnumerationProperty | ||
fromJSON(enumerationPropertyProps: EnumerationPropertyProps): Promise<void> | ||
fromJSONSync(enumerationPropertyProps: EnumerationPropertyProps): void | ||
toJSON(): EnumerationPropertyProps | Save this EnumerationProperty's properties to an object for serializing to JSON. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addCustomAttribute(customAttribute: CustomAttribute): void Protected | PrimitiveOrEnumPropertyBase | |
getCategorySync(): undefined | PropertyCategory | PrimitiveOrEnumPropertyBase | |
getCustomAttributes(): Promise<> | PrimitiveOrEnumPropertyBase | Retrieve all custom attributes in the current property and its base |
getCustomAttributesSync(): | PrimitiveOrEnumPropertyBase | Retrieve all custom attributes in the current property and its base. |
getKindOfQuantitySync(): undefined | KindOfQuantity | PrimitiveOrEnumPropertyBase | |
isArray(): this is AnyArrayProperty | PrimitiveOrEnumPropertyBase | |
isEnumeration(): this is AnyEnumerationProperty | PrimitiveOrEnumPropertyBase | |
isNavigation(): this is NavigationProperty | PrimitiveOrEnumPropertyBase | |
isPrimitive(): this is AnyPrimitiveProperty | PrimitiveOrEnumPropertyBase | |
isStruct(): this is AnyStructProperty | PrimitiveOrEnumPropertyBase |
Properties
Name | Type | Description | |
---|---|---|---|
_enumeration Protected | undefined | LazyLoadedEnumeration | ||
enumeration Accessor ReadOnly | undefined | LazyLoadedEnumeration |
Inherited properties
Defined in
Last Updated: 20 June, 2023