SchemaCache Class
Beta
Implements
Methods
Name | Description | |
---|---|---|
constructor(): SchemaCache | ||
addSchema<T extends Schema<T>>(schema: T): Promise<void> | Adds a schema to the cache. | |
addSchemaSync<T extends Schema<T>>(schema: T): void | Adds a schema to the cache. | |
getAllSchemas(): Schema[] | Gets all the schemas from the schema cache. | |
getSchema<T extends Schema<T>>(schemaKey: SchemaKey, matchType: SchemaMatchType = SchemaMatchType.Latest): Promise<undefined | T> | Gets the schema which matches the provided SchemaKey. | |
getSchemaItems(): IterableIterator<SchemaItem> | Generator function that can iterate through each schema in _schema SchemaMap and items for each Schema | |
getSchemaSync<T extends Schema<T>>(schemaKey: SchemaKey, matchType: SchemaMatchType = SchemaMatchType.Latest): undefined | T |
Properties
Name | Type | Description | |
---|---|---|---|
count Accessor ReadOnly | number |
Defined in
Last Updated: 20 June, 2023