ISchemaLocater Interface
Beta
The interface defines what is needed to be a ISchemaLocater, which are used in a SchemaContext.
Implemented by
Methods
Name | Description | |
---|---|---|
getSchema<T extends Schema<T>>(schemaKey: SchemaKey, matchType: SchemaMatchType, context?: SchemaContext): Promise<undefined | T> | Attempts to get a schema from the locater. | |
getSchemaSync<T extends Schema<T>>(schemaKey: SchemaKey, matchType: SchemaMatchType, context?: SchemaContext): undefined | T | Attempts to get a schema from the locater. |
Defined in
Last Updated: 20 June, 2023