IModelTransformOptions Interface
Beta
Options provided to the IModelTransformer constructor.
note if adding an option, you must explicitly add its serialization to IModelTransformer.saveStateToFile!
Properties
Name | Type | Description | |
---|---|---|---|
cloneUsingBinaryGeometry | undefined | boolean | Flag that indicates whether or not the transformation process should clone using binary geometry. | |
danglingPredecessorsBehavior | "reject" | "ignore" | The behavior to use when an element reference (id) is found stored as a reference on an element in the source, | Deprecated Beta |
danglingReferencesBehavior | "reject" | "ignore" | The behavior to use when an element reference (id) is found stored as a reference on an element in the source, | Beta |
includeSourceProvenance | undefined | boolean | Set to true to clone existing source provenance into the target. |
|
isReverseSynchronization | undefined | boolean | Flag that indicates that the current source and target iModels are now synchronizing in the reverse direction from a prior synchronization. | |
loadSourceGeometry | undefined | boolean | Flag that indicates whether or not the transformation process needs to consider the source geometry before cloning/transforming. | |
noProvenance | undefined | boolean | Set to true if IModelTransformer should not record its provenance. |
|
optimizeGeometry | undefined | OptimizeGeometryOptions | If defined, options to be supplied to IModelImporter.optimizeGeometry by IModelTransformer.processChanges and IModelTransformer.processAll | Beta |
preserveElementIdsForFiltering | undefined | boolean | Flag that indicates that ids should be preserved while copying elements to the target | Beta |
targetScopeElementId | undefined | string | The Id of the Element in the target iModel that represents the source repository as a whole and scopes its ExternalSourceAspect instances. | |
wasSourceIModelCopiedToTarget | undefined | boolean | Flag that indicates that the target iModel was created by copying the source iModel. |
Defined in
Last Updated: 20 June, 2023