optimizeGeometry Method
Examine the geometry streams of every GeometricElement3d in the target iModel and apply the specified optimizations.
optimizeGeometry(options: OptimizeGeometryOptions): void
note This method is automatically called from IModelTransformer.processChanges and IModelTransformer.processAll if IModelTransformOptions.optimizeGeometry is defined.
Parameter | Type | Description |
---|---|---|
options | OptimizeGeometryOptions |
Returns - void
Defined in
- transformer/src/IModelImporter.ts Line 547
Last Updated: 20 June, 2023