saveStateToFile Method
Save the state of the active transformation to a file path, if a file at the path already exists, it will be overwritten This state can be used by IModelTransformer.resumeTransformation to resume a transformation from this point. The serialization format is a custom sqlite database.
saveStateToFile(nativeStatePath: string): void
note custom transformers with custom state may override IModelTransformer.saveStateToDb or IModelTransformer.getAdditionalStateJson and IModelTransformer.loadStateFromDb (with a super call) or IModelTransformer.loadAdditionalStateJson if they have custom state that needs to be stored with potentially inside the same sqlite file in separate tables
Parameter | Type | Description |
---|---|---|
nativeStatePath | string |
Returns - void
Defined in
- transformer/src/IModelTransformer.ts Line 1488
Last Updated: 20 June, 2023