IModelExportHandler Class
Beta
Handles the events generated by IModelExporter.
note Change information is available when IModelExportHandler
methods are invoked via IModelExporter.exportChanges, but not available when invoked via IModelExporter.exportAll.
note The handler is intended to be owned by (registered with) and called from the IModelExporter exclusively
see iModel Transformation and Data Exchange, IModelExporter
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): IModelExportHandler | ||
onDeleteElement(_elementId: string): void | Called when an element should be deleted. | |
onDeleteModel(_modelId: string): void | Called when a model should be deleted. | |
onDeleteRelationship(_relInstanceId: string): void | Called when a relationship should be deleted. | |
onExportCodeSpec(_codeSpec: CodeSpec, _isUpdate: undefined | boolean): void | Called when a CodeSpec should be exported. | |
onExportElement(_element: Element, _isUpdate: undefined | boolean): void | Called when an element should be exported. | |
onExportElementMultiAspects(_aspects: ElementMultiAspect[]): void | Called when ElementMultiAspects should be exported. | |
onExportElementUniqueAspect(_aspect: ElementUniqueAspect, _isUpdate: undefined | boolean): void | Called when an ElementUniqueAspect should be exported. | |
onExportFont(_font: FontProps, _isUpdate: undefined | boolean): void | Called when a font should be exported. | |
onExportModel(_model: Model, _isUpdate: undefined | boolean): void | Called when a model should be exported. | |
onExportRelationship(_relationship: Relationship, _isUpdate: undefined | boolean): void | Called when a Relationship should be exported. | |
onExportSchema(_schema: Schema): Promise<void | ExportSchemaResult> | Called when a schema should be exported. | |
onProgress(): Promise<void> | This method is called when IModelExporter has made incremental progress based on the IModelExporter.progressInterval setting. | |
shouldExportCodeSpec(_codeSpec: CodeSpec): boolean | If true is returned, then the CodeSpec will be exported. |
|
shouldExportElement(_element: Element): boolean | If true is returned, then the element will be exported. |
|
shouldExportElementAspect(_aspect: ElementAspect): boolean | If true is returned, then the ElementAspect will be exported. |
|
shouldExportRelationship(_relationship: Relationship): boolean | If true is returned, then the relationship will be exported. |
|
shouldExportSchema(_schemaKey: SchemaKey): boolean | If true is returned, then the schema will be exported. |
Defined in
Last Updated: 20 June, 2023