LabeledSelectProps Interface
Deprecated in 3.0. Use LabeledSelectProps in itwinui-react instead
Properties for LabeledSelect components
Extends
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
inputClassName | undefined | string | LabeledComponentProps | Custom CSS class name for the checkbox input element |
inputStyle | undefined | CSSProperties | LabeledComponentProps | Custom CSS Style for the checkbox input element |
itemId | undefined | string | SelectProps | Optional unique identifier for item. |
label | undefined | string | LabeledComponentProps | Text that will be shown next to or above the input. |
labelClassName | undefined | string | LabeledComponentProps | Custom CSS class name for the label |
labelStyle | undefined | CSSProperties | LabeledComponentProps | Custom CSS Style for the label |
undefined | string | MessagedComponentProps | Optional text shown below the input. | |
undefined | string | MessagedComponentProps | Custom CSS class name for the message | |
undefined | CSSProperties | MessagedComponentProps | Custom CSS Style for the message | |
options | string | SelectOption[] | { T } | SelectProps | Options for Select dropdown. |
ref | undefined | Ref<HTMLSelectElement> | SelectProps | Provides ability to return reference to HTMLSelectElement |
setFocus | undefined | boolean | SelectProps | Indicates whether to set focus to the select element |
status | undefined | InputStatus | LabeledComponentProps | Input status like: "Success", "Warning" or "Error" |
Defined in
Last Updated: 20 June, 2023