SelectProps Interface
Deprecated in 3.0. Use SelectProps in itwinui-react instead
Properties for Select component
Extends
- SelectHTMLAttributes<HTMLSelectElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
options | string | SelectOption[] | { T } | Options for Select dropdown. | |
ref | undefined | Ref<HTMLSelectElement> | Provides ability to return reference to HTMLSelectElement | |
setFocus | undefined | boolean | Indicates whether to set focus to the select element |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 20 June, 2023