RotationalSweep Class
A LinearSweep is
- A planar contour (any Loop, Path, or parityRegion)
- An axis vector.
- The planar contour is expected to be in the plane of the axis vector
- The contour may have points and/or lines that are on the axis, but otherwise is entirely on one side of the axis.
- A sweep angle.
Extends
Methods
Name |
Description |
|
clone(): RotationalSweep |
return a deep clone |
|
cloneAxisRay(): Ray3d |
return clone of (not reference to) the axis vector. |
|
cloneTransformed(transform: Transform): RotationalSweep |
return a cloned transform. |
|
constantVSection(vFraction: number): undefined | CurveCollection |
Return the curves of a constant-v section of the solid. |
|
dispatchToGeometryHandler(handler: GeometryHandler): any |
Dispatch to strongly typed handler handler.handleRotationalSweep(this) |
|
extendRange(range: Range3d, transform?: Transform): void |
Extend range using sampled points on the surface. |
|
getConstructiveFrame(): undefined | Transform |
Return a coordinate frame (right handed unit vectors) |
|
getCurves(): CurveCollection |
Return (REFERENCE TO) the swept curves. |
|
getFractionalRotationTransform(vFraction: number, result?: Transform): Transform |
Return a transform that rotates around the rotational axis by a fraction of the total sweep. |
|
getSweep(): Angle |
Return the sweep angle. |
|
getSweepContourRef(): SweepContour |
Return (REFERENCE TO) the swept curves with containing plane markup. |
|
isAlmostEqual(other: GeometryQuery): boolean |
Test for same axis, capping, and swept geometry. |
|
isSameGeometryClass(other: any): boolean |
Test if other is a RotationalSweep |
|
tryTransformInPlace(transform: Transform): boolean |
Transform the contour and axis |
|
create(contour: CurveCollection, axis: Ray3d, sweepAngle: Angle, capped: boolean): undefined | RotationalSweep Static |
Create a rotational sweep. |
|
Inherited methods
Properties
Name |
Type |
Description |
|
isClosedVolume Accessor ReadOnly |
boolean |
|
|
solidPrimitiveType Readonly |
"rotationalSweep" |
String name for schema properties |
|
Inherited properties
Defined in
Last Updated:
20 June, 2023