SweepContour Class
Sweepable contour with Transform for local to world interaction.
- The surface/solid classes
LinearSweep
,RotationalSweep
,RuledSweep
use this for their swept contours.
Methods
Name | Description | |
---|---|---|
announceFacets(announce: (facets: IndexedPolyface) => void, options: undefined | StrokeOptions): void | Emit facets to a function | |
buildFacets(options: undefined | StrokeOptions): void | build the (cached) internal facets. | |
clone(): SweepContour | Return a deep clone. | |
cloneTransformed(transform: Transform): undefined | SweepContour | Return a transformed clone. | |
emitFacets(builder: PolyfaceBuilder, reverse: boolean, transform?: Transform): void | Emit facets to a builder. | |
getCurves(): CurveCollection | Return (Reference to) the curves | |
isAlmostEqual(other: any): boolean | Test for near equality of cures and local frame. | |
purgeFacets(): void | delete existing facets. | |
sweepToUnionOfConvexClipPlaneSets(sweepVector?: Vector3d, cap0: boolean = false, cap1: boolean = false): undefined | UnionOfConvexClipPlaneSets | Triangulate the region. | |
tryTransformInPlace(transform: Transform): boolean | Apply transform to the curves, axis. |
|
createForLinearSweep(contour: CurveCollection, defaultNormal?: Vector3d): undefined | SweepContour Static | Create for linear sweep. | |
createForPolygon(points: MultiLineStringDataVariant, defaultNormal?: Vector3d): undefined | SweepContour Static | Create for linear sweep. | |
createForRotation(contour: CurveCollection, axis: Ray3d): undefined | SweepContour Static | Create for rotational sweep. |
Properties
Name | Type | Description | |
---|---|---|---|
axis | undefined | Ray3d | Axis used only in rotational case. | |
curves | CurveCollection | The underlying curve collection, in its world coordinates position. | |
localToWorld | Transform | coordinate frame that in which the curves are all in the xy plane. | |
xyStrokes Accessor ReadOnly | undefined | AnyCurve |
Defined in
- solid/SweepContour.ts Line 35
Last Updated: 20 June, 2023