TriangularFacetLocationDetail Class
Implementation of FacetLocationDetail
for a triangular facet.
Implements
Methods
Name | Description | |
---|---|---|
clone(): TriangularFacetLocationDetail | Clone the instance | |
copyContentsFrom(other: TriangularFacetLocationDetail): void | Set the instance contents from the other detail. | |
getBarycentricCoordinates(): number[] | Get the barycentric coordinates of this location. | |
getColor(facetColors?: number[]): undefined | number | Get color interpolated from facet data. | |
getNormal(facetNormals?: IndexedXYZCollection): undefined | Vector3d | Get normal interpolated from facet data. | |
getParam(facetParams?: IndexedXYCollection): undefined | Point2d | Get uv parameter interpolated from facet data. | |
invalidate(deep: boolean = true): void | Invalidate this detail. | |
create(facetIndex: number, detail?: TriangleLocationDetail, result?: TriangularFacetLocationDetail): TriangularFacetLocationDetail Static | Create a detail. |
Properties
Name | Type | Description | |
---|---|---|---|
a Accessor ReadOnly | number | Get the application-specific number. | |
classify Accessor ReadOnly | PolygonLocation | Get the code that classifies the location of the point with respect to the facet. | |
closestEdge Accessor ReadOnly | { edgeParam: number, startVertexIndex: number } | Get the projection of the point onto the closest facet edge. | |
edgeCount Accessor ReadOnly | number | Get the edge count of this facet. | |
facetIndex Accessor ReadOnly | number | Get the facet index. | |
isConvex Accessor ReadOnly | boolean | Whether the facet is convex. | |
isInsideOrOn Accessor ReadOnly | boolean | Whether the point is inside or on the polygon. | |
isValid Accessor ReadOnly | boolean | Whether this instance specifies a valid location. | |
point Accessor ReadOnly | Point3d | Get the world coordinates of the point. |
Defined in
- polyface/FacetLocationDetail.ts Line 94
Last Updated: 20 June, 2023