IndexedXYZCollectionPolygonOps Class
IndexedXYZCollectionPolygonOps
class contains static methods for typical operations on polygons carried as IndexedXyZCollection
Methods
Name | Description | |
---|---|---|
constructor(): IndexedXYZCollectionPolygonOps | ||
clipConvexPolygonInPlace(plane: PlaneAltitudeEvaluator, xyz: GrowableXYZArray, work: GrowableXYZArray, keepPositive: boolean = true, tolerance: number = Geometry.smallMetricDistance): number Static | Clip a polygon to one side of a plane. | |
intersectRangeConvexPolygonInPlace(range: Range3d, xyz: GrowableXYZArray): undefined | GrowableXYZArray Static | Return the intersection of the plane with a range cube. | |
splitConvexPolygonInsideOutsidePlane(plane: PlaneAltitudeEvaluator, xyz: IndexedReadWriteXYZCollection, xyzPositive: IndexedReadWriteXYZCollection, xyzNegative: IndexedReadWriteXYZCollection, altitudeRange: Range1d): void Static | Split a (convex) polygon into 2 parts based on altitude evaluations. |
Defined in
- geometry3d/PolygonOps.ts Line 1206
Last Updated: 20 June, 2023