PlaneAltitudeEvaluator Interface
Interface so various plane representations can be used by algorithms that just want altitude evaluations.
Specific implementors are
- Plane3dByOriginAndUnitNormal
- Point4d (used for homogeneous plane coefficients)
Implemented by
Methods
Name | Description | |
---|---|---|
altitude(point: Point3d): number | Return the altitude of the point from the plane. | |
altitudeXYZ(x: number, y: number, z: number): number | Return the altitude of the point from the plane, with the point supplied as simple x,y,z | |
normalX(): number | x part of normal vector | |
normalY(): number | x part of normal vector | |
normalZ(): number | x part of normal vector | |
velocity(vector: Vector3d): number | Return the derivative of altitude wrt motion along a vector. | |
velocityXYZ(x: number, y: number, z: number): number | Return the derivative of altitude wrt motion along a vector given by components | |
weightedAltitude(point: Point4d): number | Return the weighted altitude |
Defined in
- Geometry.ts Line 102
Last Updated: 20 June, 2023