NullGeometryHandler Class
NullGeometryHandler
is a base class for dispatching various geometry types to
application specific implementation of some service.
To use:
- Derive a class from
NullGeometryHandler
- Reimplement any or all of the specific
handleXXXX
methods - Create a handler instance
myHandler
- To send a
GeometryQuery
objectcandidateGeometry
through the (fast) dispatch, invoke `candidateGeometry.dispatchToHandler (myHandler) - The appropriate method or methods will get called with a strongly typed
_g
value.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): NullGeometryHandler | ||
handleAkimaCurve3d(_g: AkimaCurve3d): any | no-action implementation | |
handleArc3d(_g: Arc3d): any | no-action implementation | |
handleBSplineCurve3d(_g: BSplineCurve3d): any | no-action implementation | |
handleBSplineCurve3dH(_g: BSplineCurve3dH): any | no-action implementation | |
handleBSplineSurface3d(_g: BSplineSurface3d): any | no-action implementation | |
handleBSplineSurface3dH(_g: BSplineSurface3dH): any | no-action implementation | |
handleBagOfCurves(_g: BagOfCurves): any | no-action implementation | |
handleBezierCurve3d(_g: BezierCurve3d): any | no-action implementation | |
handleBezierCurve3dH(_g: BezierCurve3dH): any | no-action implementation | |
handleBox(_g: Box): any | no-action implementation | |
handleCone(_g: Cone): any | no-action implementation | |
handleCoordinateXYZ(_g: CoordinateXYZ): any | no-action implementation | |
handleCurveCollection(_g: CurveCollection): any | no-action implementation | |
handleIndexedPolyface(_g: IndexedPolyface): any | no-action implementation | |
handleInterpolationCurve3d(_g: InterpolationCurve3d): any | no-action implementation | |
handleLineSegment3d(_g: LineSegment3d): any | no-action implementation | |
handleLineString3d(_g: LineString3d): any | no-action implementation | |
handleLinearSweep(_g: LinearSweep): any | no-action implementation | |
handleLoop(_g: Loop): any | no-action implementation | |
handleParityRegion(_g: ParityRegion): any | no-action implementation | |
handlePath(_g: Path): any | no-action implementation | |
handlePointString3d(_g: PointString3d): any | no-action implementation | |
handleRotationalSweep(_g: RotationalSweep): any | no-action implementation | |
handleRuledSweep(_g: RuledSweep): any | no-action implementation | |
handleSphere(_g: Sphere): any | no-action implementation | |
handleTorusPipe(_g: TorusPipe): any | no-action implementation | |
handleUnionRegion(_g: UnionRegion): any | no-action implementation |
Defined in
- geometry3d/GeometryHandler.ts Line 123
Last Updated: 20 June, 2023