LinearSweep Class
A LinearSweep is a SolidPrimitive
defined by
- A set of curves (any Loop, Path, or parityRegion)
- A sweep vector
If the object is "capped", the curves must be planar.
Extends
Methods
Name |
Description |
|
clone(): LinearSweep |
Return a deep clone |
|
cloneSweepVector(): Vector3d |
return a clone of the sweep vector |
|
cloneTransformed(transform: Transform): LinearSweep |
Return a transformed clone |
|
constantVSection(vFraction: number): undefined | CurveCollection |
Return the curves at a fraction along the sweep direction. |
|
dispatchToGeometryHandler(handler: GeometryHandler): any |
Invoke strongly typed handler.handleLinearSweep(this) |
|
extendRange(rangeToExtend: Range3d, transform?: Transform): void |
Extend rangeToExtend to include this geometry. |
|
getConstructiveFrame(): undefined | Transform |
Return a coordinate frame (right handed unit vectors) |
|
getCurvesRef(): CurveCollection |
get a reference to the swept curves |
|
getSweepContourRef(): SweepContour |
Get a reference to the SweepContour carrying the plane of the curves |
|
isAlmostEqual(other: GeometryQuery): boolean |
Test for near-equality of coordinates in other |
|
isSameGeometryClass(other: any): boolean |
Test if other is also an instance of LinearSweep |
|
tryTransformInPlace(transform: Transform): boolean |
apply a transform to the curves and sweep vector |
|
create(contour: CurveCollection, direction: Vector3d, capped: boolean): undefined | LinearSweep Static |
Create a sweep of a starting contour. |
|
createZSweep(xyPoints: Readonly<WritableXAndY>[], z: number, zSweep: number, capped: boolean): undefined | LinearSweep Static |
Create a z-direction sweep of the polyline or polygon given as xy linestring values. |
|
Inherited methods
Properties
Name |
Type |
Description |
|
isClosedVolume Accessor ReadOnly |
boolean |
|
|
solidPrimitiveType Readonly |
"linearSweep" |
String name for schema properties |
|
Inherited properties
Defined in
Last Updated:
20 June, 2023