ViewPose2d Class
The "pose" for a ViewState2d.
extensions
Extends
Methods
Name | Description | |
---|---|---|
constructor(view: ViewState2d): ViewPose2d | Construct a pose from the specified 2d view. |
Properties
Name | Type | Description | |
---|---|---|---|
angle Readonly | Angle | The rotation of the view. | |
delta Readonly | Point2d | The 2d extents of the view. | |
origin2d Readonly | Point2d | The 2d origin of the view. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
cameraOn | boolean | ViewPose | True if the camera is enabled. |
center Accessor ReadOnly | Point3d | ViewPose | Computes the center of the viewed volume. |
target Accessor ReadOnly | Point3d | ViewPose | Returns the target point of the view. This is the same as ViewPose.center unless ViewPose.cameraOn is true . |
undoTime | undefined | BeTimePoint | ViewPose | The time at which this pose was created, if it was saved into a Viewport's undo stack. |
zVec Accessor ReadOnly | Vector3d | ViewPose | Computes the Z vector of the ViewPose.rotation matrix. |
Defined in
- core/frontend/src/ViewPose.ts Line 124
Last Updated: 20 June, 2023