BeTimePoint Class
A specific point in time relative to the current time. BeTimePoints are used for timing operations. They are created from a BeDuration relative to the "now". BeTimePoints are immutable.
Methods
Name | Description | |
---|---|---|
after(other: BeTimePoint): boolean | Determine whether this BeTimePoint happens after another one. | |
before(other: BeTimePoint): boolean | Determine whether this BeTimePoint happens before another one. | |
minus(duration: BeDuration): BeTimePoint | Subtract a BeDuration from this BeTimePoint, returning a new BeTimePoint. | |
plus(duration: BeDuration): BeTimePoint | Subtract a BeDuration from this BeTimePoint, returning a new BeTimePoint. | |
beforeNow(val: BeDuration): BeTimePoint Static | Create a BeTimePoint at a specified duration in the past before now | |
fromNow(val: BeDuration): BeTimePoint Static | Create a BeTimePoint at a specified duration in the future from now | |
now(): BeTimePoint Static | Create a BeTimePoint from Date.now() |
Properties
Defined in
- core/bentley/src/Time.ts Line 87
Last Updated: 20 June, 2023