animateFrustumChange Method
Queue an animation that interpolates between this viewport's previous Frustum and its current frustum. This function is typically called by ViewTools after modifying the viewport's ViewState, to smoothly transition to the new view; as opposed to calling ScreenViewport.synchWithView which immediately transitions to the new view. It uses FrustumAnimator to perform the animation.
animateFrustumChange(options?: ViewAnimationOptions): void
Parameter | Type | Description |
---|---|---|
options | ViewAnimationOptions |
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 3211
Last Updated: 20 June, 2023