ViewAnimationOptions Interface
Options that control how an Viewport animation behaves.
extensions
Methods
Name | Description | |
---|---|---|
animationFinishedCallback(didComplete: boolean): void Optional | Invoked when the animator is finished. |
Properties
Name | Type | Description | |
---|---|---|---|
animationTime | undefined | number | Amount of time for animation, in milliseconds. | |
cancelOnAbort | undefined | boolean | if animation is aborted, don't move to end, leave at current point instead. | |
easingFunction | undefined | EasingFunction | easing function for animation. |
Defined in
Last Updated: 20 June, 2023