FrustumAnimator Class
Animates the transition of a Viewport from one Frustum to another. The viewport will render as many frames as necessary during the supplied duration.
see Viewport.animateFrustumChange to conveniently animate a viewport from one frustum to another.
extensions
Implements
Methods
Name | Description | |
---|---|---|
constructor(options: ViewAnimationOptions, viewport: ScreenViewport, begin: ViewPose, end: ViewPose): FrustumAnimator | Construct an animator that animates from begin to end . |
Properties
Name | Type | Description | |
---|---|---|---|
options | ViewAnimationOptions |
Defined in
Last Updated: 20 June, 2023