Animator Interface
An object to animate a transition of a Viewport. Only one animator may be associated with a viewport at a time. Registering a new animator interrupts and replaces any existing animator. The animator's animate() function will be invoked just prior to the rendering of each frame. The animator may be removed in response to certain changes to the viewport - e.g., when the viewport is closed, or viewing tools operate on it, etc.
see Viewport.setAnimator to apply an animator to a viewport.
extensions
Implemented by
Methods
Name | Description | |
---|---|---|
animate(): boolean | Apply animation to the viewport. | |
interrupt(): void | Invoked to abort this Animator. |
Defined in
Last Updated: 20 June, 2023