GetPixelDataWorldPointArgs Interface
Arguments to Viewport.getPixelDataWorldPoint.
Properties
Name | Type | Description | |
---|---|---|---|
out | undefined | Point3d | If supplied, this point will be modified to store the returned point, instead of allocating a new point. | |
pixels | Pixel.Buffer | The buffer containing the pixel data. | |
preserveModelDisplayTransforms | undefined | boolean | If true, then the world point of a pixel associated with a model will preserve any transforms applied to the model at display time, | |
x | number | The x coordinate of the pixel of interest, in view coordinates. | |
y | number | The y coordinate of the pixel of interest, in view coordinates. |
Defined in
- core/frontend/src/Viewport.ts Line 188
Last Updated: 20 June, 2023