Pixel.Buffer Interface
A rectangular array of pixels as read from a Viewport's frame buffer. Each pixel is represented as a Pixel.Data object. The contents of the pixel buffer will be specified using device pixels, not CSS pixels. See Viewport.devicePixelRatio and Viewport.cssPixelsToDevicePixels.
see Viewport.readPixels.
Methods
Name | Description | |
---|---|---|
getPixel(x: number, y: number): Pixel.Data | Retrieve the data associated with the pixel at (x,y) in view coordinates. |
Defined in
- core/frontend/src/render/Pixel.ts Line 124
Last Updated: 20 June, 2023