Pixel.Data Class
Describes a single pixel within a Pixel.Buffer.
Properties
Name | Type | Description | |
---|---|---|---|
distanceFraction Readonly | number | The pixel's depth in CoordSystem.Npc coordinates (0 to 1), or -1 if depth was not written or not requested. | |
elementId Accessor ReadOnly | undefined | string | The Id of the element that produced the pixel. | |
feature Readonly | undefined | Feature | The feature that produced the pixel. | |
geometryClass Accessor ReadOnly | undefined | GeometryClass | The class of geometry that produced the pixel. | |
iModel Readonly | undefined | IModelConnection | The iModel from which the geometry producing the pixel originated. | |
modelId Readonly | undefined | string | ||
planarity Readonly | Pixel.Planarity | The planarity of the geometry that produced the pixel. | |
subCategoryId Accessor ReadOnly | undefined | string | The Id of the SubCategory that produced the pixel. | |
type Readonly | Pixel.GeometryType | The type of geometry that produced the pixel. |
Defined in
Last Updated: 20 June, 2023