CustomGraphicBuilderOptions Interface
Options for creating a GraphicBuilder to produce a RenderGraphic that is not associated with any particular Viewport and may not be associated with any particular IModelConnection. This is primarily useful when the same graphic is to be saved and reused for display in multiple viewports and for which a chord tolerance can be computed independently of each viewport's Frustum.
extensions
Extends
Methods
Name | Description | |
---|---|---|
computeChordTolerance(args: ComputeChordToleranceArgs): number | A function that can compute the level of detail for the graphics produced by the builder. |
Properties
Name | Type | Description | |
---|---|---|---|
applyAspectRatioSkew | undefined | undefined | ||
iModel | undefined | IModelConnection | Optionally, the IModelConnection with which the graphic is associated. | |
viewport | undefined | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
generateEdges | undefined | boolean | GraphicBuilderOptions | Controls whether edges are generated for surfaces. |
pickable | undefined | PickableGraphicOptions | GraphicBuilderOptions | If the graphic is to be pickable, specifies the pickable Id and other options. |
placement | undefined | Transform | GraphicBuilderOptions | The local-to-world transform in which the builder's geometry is to be defined - by default, an identity transform. |
preserveOrder | undefined | boolean | GraphicBuilderOptions | If true, the order in which geometry is added to the builder is preserved. |
type | GraphicType | GraphicBuilderOptions | The type of graphic to produce. |
viewIndependentOrigin | undefined | Point3d | GraphicBuilderOptions | If defined, specifies a point about which the graphic will rotate such that it always faces the viewer. |
wantNormals | undefined | boolean | GraphicBuilderOptions | Controls whether normals are generated for surfaces. |
Defined in
Last Updated: 20 June, 2023