ComputeChordToleranceArgs Interface
Arguments used to compute the chord tolerance (level of detail) of the RenderGraphics produced by a GraphicBuilder. Generally, the chord tolerance should be roughly equivalent to the size in meters of one pixel on screen where the graphic is to be displayed. For GraphicType.ViewOverlay and GraphicType.ViewBackground, which already define their geometry in pixels, the chord tolerance should typically be 1.
see CustomGraphicBuilderOptions.computeChordTolerance.
extensions
Methods
Name | Description | |
---|---|---|
computeRange(): Range3d Readonly | A function that computes a range enclosing all of the geometry that was added to the builder. |
Properties
Name | Type | Description | |
---|---|---|---|
graphic Readonly | GraphicBuilder | The graphic builder being used to produce the graphics. |
Defined in
Last Updated: 20 June, 2023