BatchOptions Interface
Options used when constructing a Batch
- that is, a RenderGraphic with an associated FeatureTable describing individual Features within the
graphic. Individual features can be resymbolized in a variety of ways including flashing and hiliting.
For example, to prevent graphics produced by readElementGraphics from being hilited when their corresponding element is in the SelectionSet,
pass { noHilite: true }
to readElementGraphics.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
locateOnly | undefined | boolean | If true, the contents of the batch will only be drawn by Viewport.readPixels, not Viewport.renderFrame, causing them to be locatable but invisible. | |
noEmphasis | undefined | boolean | If true, features within the batch will not be emphasized when the corresponding BatchOptions.Feature is emphasized using FeatureOverrides. | |
noFlash | undefined | boolean | If true, features within the batch will not be flashed on mouseover. | |
noHilite | undefined | boolean | If true, features within the batch will not be hilited when their corresponding element is in the SelectionSet. | |
tileId | undefined | string | Identifies the Tile associated with the batch, chiefly for debugging purposes. | Beta |
Defined in
Last Updated: 20 June, 2023