readElementGraphics Function
Convert the byte array returned by TileAdmin.requestElementGraphics into a RenderGraphic.
readElementGraphics(bytes: Uint8Array, iModel: IModelConnection, modelId: string, is3d: boolean, options?: | BatchOptions): Promise<RenderGraphic | undefined>
extensions
Parameter | Type | Description |
---|---|---|
bytes | Uint8Array | The binary graphics data obtained from requestElementGraphics . |
iModel | IModelConnection | The iModel with which the graphics are associated. |
modelId | string | The Id of the GeometricModelState with which the graphics are associated. Can be an invalid Id. |
is3d | boolean | True if the graphics are 3d. |
options | | BatchOptions | Options customizing how Features within the graphic can be resymbolized; or false if you don't want to produce a batch. |
Returns - Promise<RenderGraphic | undefined>
Defined in
- core/frontend/src/tile/ImdlReader.ts Line 102
Last Updated: 20 June, 2023