IntersectDetail Class
extensions
Extends
Methods
Name | Description | |
---|---|---|
constructor(from: SnapDetail, heat: SnapHeat = SnapHeat.None, snapPoint: XYZProps, otherPrimitive: CurvePrimitive, otherId: string): IntersectDetail | Constructor for SnapDetail. | |
draw(context: DecorateContext): void | Draw this HitDetail as a Decoration. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(): SnapDetail | SnapDetail | Make a copy of this SnapDetail. |
getCurvePrimitive(singleSegment: boolean = true): undefined | CurvePrimitive | SnapDetail | |
getHitType(): HitDetailType | SnapDetail | Returns HitDetailType.Snap |
getPoint(): Point3d | SnapDetail | Get the snap point if this SnapDetail is hot, the pick point otherwise. |
getToolTip(): Promise<string | HTMLElement> | SnapDetail | Get the tooltip content for this HitDetail. |
isSameHit(otherHit?: HitDetail): boolean | SnapDetail | Determine if this HitPoint is from the same source as another HitDetail. |
setCurvePrimitive(primitive?: CurvePrimitive, localToWorld?: Transform, geomType?: HitGeomType): void | SnapDetail | Set curve primitive and HitGeometryType for this SnapDetail. |
setSnapPoint(point: Point3d, heat: SnapHeat): void | SnapDetail | Change the snap point. |
Properties
Name | Type | Description | |
---|---|---|---|
otherId Readonly | string | ||
otherPrimitive Readonly | CurvePrimitive |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
adjustedPoint Readonly | Point3d | SnapDetail | AccuSnap/AccuDraw can adjust the point after the snap. |
distFraction Readonly | number | SnapDetail | |
distXY Readonly | number | SnapDetail | |
geometryClass Readonly | undefined | GeometryClass | SnapDetail | |
geomType | undefined | HitGeomType | SnapDetail | The HitGeomType of this SnapDetail |
heat | SnapHeat | SnapDetail | |
hitPoint Readonly | Point3d | SnapDetail | |
hitSource Readonly | HitSource | SnapDetail | |
iModel Accessor ReadOnly | IModelConnection | SnapDetail | The IModelConnection from which the hit originated. In some cases this may not be the same as the iModel associated with the Viewport - for example, if a TiledGraphicsProvider is used to display graphics from a different iModel in the viewport. This HitDetail's element, subcategory, and model Ids are defined in the context of this IModelConnection. |
isElementHit Accessor ReadOnly | boolean | SnapDetail | Return whether sourceId is for a persistent element and not a pickable decoration. |
isExternalIModelHit Accessor ReadOnly | boolean | SnapDetail | Returns true if this hit originated from an IModelConnection other than the one associated with the Viewport. |
isHot Accessor ReadOnly | boolean | SnapDetail | Return true if the pick point was closer than the snap aperture from the generated snap point. |
isMapHit Accessor ReadOnly | boolean | SnapDetail | |
isModelHit Accessor ReadOnly | boolean | SnapDetail | |
isPointAdjusted Accessor ReadOnly | boolean | SnapDetail | Determine whether the SnapDetail.adjustedPoint is different than the SnapDetail.snapPoint. This happens, for example, when points are adjusted for grids, acs plane snap, and AccuDraw. |
modelId Readonly | undefined | string | SnapDetail | |
normal | undefined | Vector3d | SnapDetail | Surface normal at snapPoint |
parentGeomType | undefined | HitParentGeomType | SnapDetail | The HitGeomType of this SnapDetail |
primitive | undefined | CurvePrimitive | SnapDetail | Curve primitive for snap. |
priority Readonly | HitPriority | SnapDetail | |
snapMode | SnapMode | SnapDetail | |
snapPoint Readonly | Point3d | SnapDetail | HitPoint adjusted by snap |
sourceId Readonly | string | SnapDetail | |
sprite | undefined | Sprite | SnapDetail | A sprite to show the user the type of snap performed |
subCategoryId Readonly | undefined | string | SnapDetail | |
testPoint Readonly | Point3d | SnapDetail | |
viewport Readonly | ScreenViewport | SnapDetail |
Defined in
- core/frontend/src/HitDetail.ts Line 361
Last Updated: 20 June, 2023