TiledGraphicsProvider Namespace
Defined in
TiledGraphicsProvider Interface
Provides a way for applications to inject additional non-decorative graphics into a Viewport by supplying one or more TileTreeReferences capable of loading and drawing the graphics.
see Viewport.addTiledGraphicsProvider to register a provider to be drawn in a viewport.
see Exploded View Sample for an interactive demonstration of a custom provider.
extensions
Methods
Name | Description | |
---|---|---|
addToScene(context: SceneContext): void Optional | If defined, overrides the logic for adding this provider's graphics into the scene. | |
forEachTileTreeRef(viewport: Viewport, func: (ref: TileTreeReference) => void): void | For each TileTreeReference belonging to this provider that should be drawn in the specified Viewport, apply the provided function. | |
isLoadingComplete(viewport: Viewport): boolean Optional | If defined, returns true if the TileTrees required for displaying this provider's graphics in the specified Viewport are loaded and ready to draw. |
Defined in
Last Updated: 20 June, 2023