IModelAppOptions Interface
Options that can be supplied to IModelApp.startup to customize frontend behavior.
Properties
Name | Type | Description | |
---|---|---|---|
accuSnap | undefined | AccuSnap | If present, supplies the AccuSnap for this session. | |
applicationId | undefined | string | If present, supplies the Id of this application. | |
applicationVersion | undefined | string | If present, supplies the version of this application. | |
authorizationClient | undefined | AuthorizationClient | The AuthorizationClient used to obtain AccessTokens. | |
hubAccess | undefined | FrontendHubAccess | If present, supplies the FrontendHubAccess for this session. | |
localization | undefined | Localization | If present, supplies the Localization for this session. | |
mapLayerOptions | undefined | MapLayerOptions | If present, supplies Map Layer Options for this session such as Azure Access Keys | Beta |
notifications | undefined | NotificationManager | If present, supplies the NotificationManager for this session. | |
publicPath | undefined | string | If present, overrides where public assets are fetched. | Beta |
realityDataAccess | undefined | RealityDataAccess | Beta | |
renderSys | RenderSystem | RenderSystem.Options | If present, supplies an implementation of the render system, or options for initializing the default render system. | |
rpcInterfaces | undefined | RpcInterfaceDefinition<RpcInterface>[] | Deprecated | |
security | undefined | FrontendSecurityOptions | If present, supplies security options for the frontend. | |
tileAdmin | undefined | TileAdmin.Props | If present, supplies the properties with which to initialize the TileAdmin for this session. | |
toolAdmin | undefined | ToolAdmin | If present, supplies the ToolAdmin for this session. | |
uiAdmin | undefined | UiAdmin | If present, supplies the UiAdmin for this session. | |
userPreferences | undefined | UserPreferencesAccess | If present, supplies the UserPreferencesAccess for this session. | Beta |
viewManager | undefined | ViewManager | If present, supplies the ViewManager for this session. |
Defined in
- core/frontend/src/IModelApp.ts Line 80
Last Updated: 20 June, 2023