TileAdmin.Props Interface
Describes the configuration of the TileAdmin.
see TileAdmin.create
Properties
Name | Type | Description | |
---|---|---|---|
alwaysRequestEdges | undefined | boolean | If true, when requesting tile content, edges will always be requested, even if they are not required for the view. | |
cesiumIonKey | undefined | string | An API key that can be used to access content from Cesium ION like terrain meshes and OpenStreetMap Buildings meshes. | |
contextPreloadParentDepth | undefined | number | Preloading parents for context (reality and map tiles) will improve the user experience by making it more likely that tiles in nearly the required resolution will be | |
contextPreloadParentSkip | undefined | number | Preloading parents for context (reality and map tiles) will improve the user experience by making it more likely that tiles in nearly the required resolution will be | |
defaultTileSizeModifier | undefined | number | A default multiplier applied to the size in pixels of a Tile during tile selection for any Viewport. | |
disableMagnification | undefined | boolean | When producing child tiles for a given tile, two refinement strategies are considered: | |
enableExternalTextures | undefined | boolean | If true, during tile generation the backend will not embed all texture image data in the tile content. | |
enableFrontendScheduleScripts | undefined | boolean | If true, when applying a schedule script to a view, ordinary tiles will be requested and then reprocessed on the frontend to align with the script's | |
enableImprovedElision | undefined | boolean | If true, during tile generation the backend will perform tighter intersection tests to more accurately identify empty sub-volumes. | |
enableIndexedEdges | undefined | boolean | If true - and WebGL 2 is supported by the RenderSystem - when tiles containing edges are requested, request that they produce | |
enableInstancing | undefined | boolean | If true, tiles may represent repeated geometry as sets of instances. | |
generateAllPolyfaceEdges | undefined | boolean | If true then if a Polyface lacks edge visibility information, the display system will display the edges of all of its faces. | Beta |
gpuMemoryLimits | GpuMemoryLimits | GpuMemoryLimit | Defines optional limits on the total amount of GPU memory allocated to Tile contents. | |
ignoreAreaPatterns | undefined | boolean | If true, during tile generation the backend will omit geometry for area patterns. | |
maxActiveTileTreePropsRequests | undefined | number | The maximum number of simultaneously active requests for IModelTileTreeProps. | |
maximumLevelsToSkip | undefined | number | For iModel tile trees, the maximum number of levels of the tree to skip loading when selecting tiles. | |
minimumSpatialTolerance | undefined | number | If defined and greater than zero, specifies the minimum chord tolerance in meters of a tile. | |
mobileRealityTileMinToleranceRatio | undefined | number | Nominally the error on screen size of a reality tile. | |
retryInterval | undefined | number | The interval in milliseconds at which a request for tile content will be retried until a response is received. | |
tileExpirationTime | undefined | number | The minimum number of seconds to keep a Tile in memory after it has become unused. | |
tileStorage | undefined | FrontendStorage | The client side storage implementation of @itwin/object-storage-core to use for retrieving tiles from tile cache. | Beta |
tileTreeExpirationTime | undefined | number | The minimum number of seconds to keep a TileTree in memory after it has become disused. | |
useLargerTiles | undefined | boolean | Produce tiles that are larger in screen pixels to reduce the number of tiles requested and drawn by the scene. |
Defined in
- core/frontend/src/tile/TileAdmin.ts Line 1002
Last Updated: 20 June, 2023